読者です 読者をやめる 読者になる 読者になる

Express5800/110GdにFreeBSD

会社の新サーバにExpress5800/110Gdを購入して、試しにFreeBSD 6.2-Rいれてみたので、そのdmesg。

Copyright (c) 1992-2007 The FreeBSD Project.
Copyright (c) 1979, 1980, 1983, 1986, 1988, 1989, 1991, 1992, 1993, 1994
The Regents of the University of California. All rights reserved.
FreeBSD is a registered trademark of The FreeBSD Foundation.
FreeBSD 6.2-RELEASE #0: Fri Jan 12 11:05:30 UTC 2007
root@dessler.cse.buffalo.edu:/usr/obj/usr/src/sys/SMP
Timecounter "i8254" frequency 1193182 Hz quality 0
CPU: Intel(R) Pentium(R) 4 CPU 3.40GHz (3400.15-MHz 686-class CPU)
Origin = "GenuineIntel" Id = 0xf65 Stepping = 5
Features=0xbfebfbff
Features2=0xe59d,>
AMD Features=0x20000000
AMD Features2=0x1
Logical CPUs per core: 2
real memory = 2145845248 (2046 MB)
avail memory = 2094747648 (1997 MB)
ACPI APIC Table:
FreeBSD/SMP: Multiprocessor System Detected: 2 CPUs
cpu0 (BSP): APIC ID: 0
cpu1 (AP): APIC ID: 1
ioapic0 irqs 0-23 on motherboard
kbd1 at kbdmux0
ath_hal: 0.9.17.2 (AR5210, AR5211, AR5212, RF5111, RF5112, RF2413, RF5413)
acpi0: on motherboard
acpi0: Power Button (fixed)
Timecounter "ACPI-fast" frequency 3579545 Hz quality 1000
acpi_timer0: <24-bit timer at 3.579545MHz> port 0x1008-0x100b on acpi0
cpu0: on acpi0
acpi_throttle0: on cpu0
cpu1: on acpi0
acpi_throttle1: on cpu1
acpi_throttle1: failed to attach P_CNT
device_attach: acpi_throttle1 attach returned 6
pcib0: port 0xcf8-0xcff on acpi0
pci0: on pcib0
pcib1: irq 16 at device 1.0 on pci0
pci1: on pcib1
pcib2: irq 17 at device 28.0 on pci0
pci2: on pcib2
pcib3: irq 17 at device 28.4 on pci0
pci3: on pcib3
em0: port 0x4000-0x401f mem 0xdc100000-0xdc11ffff irq 16 at device 0.0 on pci3
em0: Ethernet address: 00:1d:7d:3e:89:da
pcib4: irq 16 at device 28.5 on pci0
pci4: on pcib4
uhci0: port 0x3000-0x301f irq 23 at device 29.0 on pci0
uhci0: [GIANT-LOCKED]
usb0: on uhci0
usb0: USB revision 1.0
uhub0: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub0: 2 ports with 2 removable, self powered
uhci1: port 0x3020-0x303f irq 19 at device 29.1 on pci0
uhci1: [GIANT-LOCKED]
usb1: on uhci1
usb1: USB revision 1.0
uhub1: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub1: 2 ports with 2 removable, self powered
uhci2: port 0x3040-0x305f irq 18 at device 29.2 on pci0
uhci2: [GIANT-LOCKED]
usb2: on uhci2
usb2: USB revision 1.0
uhub2: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub2: 2 ports with 2 removable, self powered
uhci3: port 0x3060-0x307f irq 16 at device 29.3 on pci0
uhci3: [GIANT-LOCKED]
usb3: on uhci3
usb3: USB revision 1.0
uhub3: Intel UHCI root hub, class 9/0, rev 1.00/1.00, addr 1
uhub3: 2 ports with 2 removable, self powered
ehci0: mem 0xdc400000-0xdc4003ff irq 23 at device 29.7 on pci0
ehci0: [GIANT-LOCKED]
usb4: EHCI version 1.0
usb4: companion controllers, 2 ports each: usb0 usb1 usb2 usb3
usb4: on ehci0
usb4: USB revision 2.0
uhub4: Intel EHCI root hub, class 9/0, rev 2.00/1.00, addr 1
uhub4: 8 ports with 8 removable, self powered
pcib5: at device 30.0 on pci0
pci10: on pcib5
pci10: at device 3.0 (no driver attached)
isab0: at device 31.0 on pci0
isa0: on isab0
atapci0: port 0x1f0-0x1f7,0x3f6,0x170-0x177,0x376,0x30a0-0x30af at device 31.1 on pci0
ata0: on atapci0
ata1: on atapci0
atapci1: port 0x30e8-0x30ef,0x30dc-0x30df,0x30e0-0x30e7,0x30d8-0x30db,0x30b0-0x30bf mem 0xdc400400-0xdc4007ff irq 19 at device 31.2 on pci0
ata2: on atapci1
ata3: on atapci1
pci0: at device 31.3 (no driver attached)
acpi_button0: on acpi0
atkbdc0: port 0x60,0x64 irq 1 on acpi0
atkbd0: irq 1 on atkbdc0
kbd0 at atkbd0
atkbd0: [GIANT-LOCKED]
psm0: irq 12 on atkbdc0
psm0: [GIANT-LOCKED]
psm0: model IntelliMouse, device ID 3
sio0: <16550A-compatible COM port> port 0x3f8-0x3ff irq 4 flags 0x10 on acpi0
sio0: type 16550A
ppc0: port 0x378-0x37f irq 7 on acpi0
ppc0: Generic chipset (NIBBLE-only) in COMPATIBLE mode
ppbus0: on ppc0
plip0: on ppbus0
lpt0: on ppbus0
lpt0: Interrupt-driven port
ppi0: on ppbus0
pmtimer0 on isa0
orm0: at iomem 0xc0000-0xc7fff,0xc8000-0xc8fff on isa0
fdc0: at port 0x3f0-0x3f5,0x3f7 irq 6 drq 2 on isa0
fdc0: [FAST]
sc0: at flags 0x100 on isa0
sc0: VGA <16 virtual consoles, flags=0x300>
sio1: configured irq 3 not in bitmap of probed irqs 0
sio1: port may not be enabled
vga0: at port 0x3c0-0x3df iomem 0xa0000-0xbffff on isa0
Timecounters tick every 1.000 msec
acd0: DVDROM at ata0-master UDMA33
ad4: 476940MB at ata2-master SATA150
ad6: 476940MB at ata3-master SATA150
SMP: AP CPU #1 Launched!
Trying to mount root from ufs:/dev/ad4s1a

これでFreeBSDが動くかどうか色々調べてみたんだけど、ネット上には動くという確証がなかったので、ちょっと不安だったんだけど全く問題なく全てのデバイスを認識してくれた。


が、これに CentOS をいれてインストール時に RAID1 を構成してインストールしたらbootしなかったので、要原因調査。

まぁブートローダーがRAID1に対応していないとかそーいうのが原因だと思うけど、解決方法が分かればいいなぁと