読者です 読者をやめる 読者になる 読者になる

php-extensions の make でエラー

小さいトラブルはいくつかあったけど、ちょっとはまったのがこの問題。

mercury# cd /usr/ports/lang/php5-extensions/
mercury# make
===>   php5-extensions-1.5 depends on file: /usr/local/include/php/main/php.h - found
===>   php5-extensions-1.5 depends on file: /usr/local/lib/php/20090626/bz2.so - not found
===>    Verifying install for /usr/local/lib/php/20090626/bz2.so in /usr/ports/archivers/php5-bz2
===>   php5-bz2-5.3.6 depends on file: /usr/local/bin/phpize - found
===>   php5-bz2-5.3.6 depends on file: /usr/local/bin/autoconf-2.68 - found
===>  PHPizing for php5-bz2-5.3.6
Configuring for:
PHP Api Version:         20090626
Zend Module Api No:      20090626
Zend Extension Api No:   220090626
autoconf: required version 2.68 not found
Error code 1
Stop in /usr/ports/archivers/php5-bz2.
Error code 1
Stop in /usr/ports/lang/php5-extensions.
Error code 1
Stop in /usr/ports/lang/php5-extensions.
autoconf-2.68 は found ってあるのに、そのしたの方で、「autoconf: required version 2.68 not found」とでて make がこけるという現象が起こった。 どうやら autoconf-wrapper 周りの状態がおかしくなっていたようで、「pkg_delete -f /var/db/pkg/auto* 」をやって、もう一度 make をしたら問題なく動いた。 このへん参考 http://forums.freebsd.org/showthread.php?t=20284